PDA

View Full Version : New Posts link not working?



Snoopy
03-18-2010, 08:51 AM
Hi, when I click on New Posts, the system tells me that there are no new posts while in facts there are several listed in the "Recent Forum Posts" section on SH Home Page. Also, the icon status on the Forum page do not reflect that there are indeed new posts in some forums (like Kim's latest comment on Cara's post in the Secular Homeschooling forum, for example). Does that "new posts" function reset at a certain time (like midnight?) or does it use a cookie? Because I didn't read those posts so I know they're new to me.

Also, I've noticed that the "Recent Forum Posts" section on the Home page is more up-to-date than the "Recent Forum Posts" section on the "Forum" page. The inconsistency bugs me. But maybe it's just me? lol. :confused:

Michael
03-18-2010, 09:15 AM
Hi Nathalie,

The new posts represent every new thread and/or reply that was made specific to your last login or visit to the forum. This way you can catch up with anything that happened while you were away.

The recent forum posts widget on the other hand shows the most recent posts in general for every user and updates in real-time.

Snoopy
03-18-2010, 10:15 AM
Michael, thanks for the reply. Throughout the day I use 2 separate computers (back and forth) and I'm logged in to SH on both. This morning I visited the SH main page on each computer but I didn't read any posts or click on any link before I clicked on "New Posts" on one of the PCs. However, the New Posts screen showed no new posts. There actually WERE posts written since my last visit on either computer, so I'm confused by your explanation.

Since there is no "see more recent posts" link in the "Recent Forum Posts", I'm limited to easily seeing the last 5 recent forum posts. And since the forum icons seem to follow the strange logic you detailed, I can't rely on that either to note if there were more than those 5 most recent forum posts. It seems that there is no way, then, for me to actually check the messages that were posted since I last read them unless I look at the Forum main page and specifically at the "last post" section and check the time the last post was posted and I think that's a bummer. I hope I don't come out as being whiny, but I did want to give you my 2 cents :)

Topsy
03-18-2010, 03:02 PM
Snoopy,

I think the New Posts thing may just be an occasional glitch. Once in a while, I'll click on it, and just like you, no new posts will come up even though there certainly are some, but most of the time it works just fine for me. Let me know if that is the case for you...

I'll see about the forum widget and see if we can update it to the same feed as the home page one...

Kerry

Snoopy
03-18-2010, 06:12 PM
Hey, thanks Topsy. You know that forum widget might be a glitch too because right after I posted that last message, it decided to make me lie and then both widgets were "coordinated". But that was the first time for me since I've been visiting here. I don't know about the New Posts link being a glitch because I only found out about that yesterday or the day before and today was the first time it told me there were no new posts. Thanks for your help :)

Snoopy
04-02-2010, 08:58 AM
OK, now this is really starting to irk me. When I came on the forum this morning and clicked on "New Posts", there were at least 8 new posts since last night when I last visited. I read a couple from the list and answered them and each time I clicked back on "New Posts" and the ones that I hadn't read were still listed as well as my newly answered ones. Then I answered a 3rd post and how the only one listed as new is that new answer from me. I didn't step away from the computer or go to another site in the meantime. This is REALLY annoying me. Why is this doing it? There doesn't seem to be a rhyme or reason to it... I see posts listed under "Most Recent Forum Posts" on the right that are new since my visit last night and that I didn't read and that are NOT listed under "New Posts". Right now the group is still small and I can try to "catch" what I have missed by accessing the Forum page and looking for the date/time stamp on the last post for each forum (since the icon for each forum is dimmed to indicate that I have read the latest posts even though I haven't), but if it gets much bigger, it's going to be a real challenge. To me, that's an important issue. Can't the system be changed so that it keeps track of the links that we click on and dimmed them/mark them "read" as we actually, individually, read them (like on any other website out there)? Sorry to sounds so upset first thing in the morning. I can get, hmmmm, unpleasant when things don't go my way. Hear that, Topsy? I'd better win that Chemistry prize. LOL (relax, it's a joke. I hope I win but David's entry had me laughing really hard so I know other entries are worthy of winning!). I'm going to go away for the day now so I won't be bugging you guys for a while. Have a nice day!

Topsy
04-02-2010, 10:30 AM
Snoopy,

There are definitely some glitches with this part of the vBulletin software. I have it give me problems on other vBulletin forums as well. Couple workarounds that I use:



I subscribe to the forum via email and get each post emailed to me (only downside is that it is a little slow...certainly not instantaneous)
When I'm already ON the forum, and it glitches and tells me there are no new posts, I click on that little link in the "no new posts" announcement that lets me view all posts in the last 24 hours. That way I can make sure I haven't missed anything.
But to me, the BEST way is when you first pull up the New Posts screen and you see all the threads that are listed, use a Windows trick to keep it there (I'm just assuming you use Windows, sorry!). Right click on each of the threads and click on "Open in a new window/tab". That way you get to read each new thread, but you never make changes on your original new posts page. That's the trick I use the most, and so far, so good.

Hope that helps a little...
Topsy

Snoopy
04-02-2010, 12:03 PM
Hey Topsy, thanks for the tips. I definitely use the last one you mentioned as I do use windows at home. I'm on my iPod right now at Perkins so I'll see if I have the same problems with the iPod.